AMT Backup 45 problems - failing to extract

AMT Backup 45 problems - failing to extract

This is a discussion on AMT Backup 45 problems - failing to extract within the Defensive Carry Guns forums, part of the Defensive Carry Discussions category; I recently put an original 45 Backup slide (without the the firing pin block) on my frame. I put a new firing pin etc. on ...

Results 1 to 7 of 7
  1. #1
    Member Array zwanboy104's Avatar
    Join Date
    Mar 2011
    Location
    York, PA
    Posts
    22

    AMT Backup 45 problems - failing to extract

    I recently put an original 45 Backup slide (without the the firing pin block) on my frame. I put a new firing pin etc. on it. Now all of a sudden I'm having FTE problems. I may get a few rounds to cycle fine, but not for long. At times every round will get stuck in the chamber.

    Even if I try to manually cycle rounds I get the same result. The last round always gets stuck on the mag follower. I tried changing them - same result. I've never had this type of problem before. Anyone have any ideas? Any help is much appreciated.


  2. #2
    los
    los is offline
    VIP Member Array los's Avatar
    Join Date
    Jan 2006
    Location
    Corpus Christi, Tx
    Posts
    2,484
    Did the replacement Slide come with an Extractor? If so, the tip may be worn or completely out of tension spec.
    What we've got here is failure to communicate.

  3. #3
    Member Array zwanboy104's Avatar
    Join Date
    Mar 2011
    Location
    York, PA
    Posts
    22
    Quote Originally Posted by los View Post
    Did the replacement Slide come with an Extractor? If so, the tip may be worn or completely out of tension spec.
    It did come with one. I decided to try and replace it with my old one which appears to look better. However, it seems to wobble a little bit. Even when I i try to manually eject/ the rounds, same result. The rounds just stay in the chamber.

  4. #4
    los
    los is offline
    VIP Member Array los's Avatar
    Join Date
    Jan 2006
    Location
    Corpus Christi, Tx
    Posts
    2,484
    The replacement Slide is probably out of spec by a few mms (too wide at the ejection port).
    What we've got here is failure to communicate.

  5. #5
    Member Array zwanboy104's Avatar
    Join Date
    Mar 2011
    Location
    York, PA
    Posts
    22
    Quote Originally Posted by los View Post
    The replacement Slide is probably out of spec by a few mms (too wide at the ejection port).
    Anything I can do about that?

  6. #6
    Member Array zwanboy104's Avatar
    Join Date
    Mar 2011
    Location
    York, PA
    Posts
    22
    Problem seems to be fixed. The extractor spring needed to be replaced with another one i had. The one on it was so compressed it wouldn't even budge. Also, another problem was the magazine followers getting tilted up. The last round would fire but the empty casing would be lodged between th follower and chamber. I fixed this by reversing the magazine springs.

    So far so good. I'm keeping my fingers crossed. Thanks for the tips LOS.

  7. #7
    los
    los is offline
    VIP Member Array los's Avatar
    Join Date
    Jan 2006
    Location
    Corpus Christi, Tx
    Posts
    2,484
    Great news, Z. Glad you got it fixed.
    What we've got here is failure to communicate.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

amt 45
,

amt 45 backup

,
amt 45 backup price
,
amt 45 backup specs
,

amt backup 45

,
amt backup 45 price
,
amt backup 45 problems
,
amt backup 45 specs
,
amt backup extractor
,
amt backup extractor problems
,
amt backup price
,
amt backup problems
Click on a term to search for related topics.

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» DefensiveCarry Sponsors