Smith 642 Problems - Page 2

Smith 642 Problems

This is a discussion on Smith 642 Problems within the General Firearm Discussion forums, part of the Related Topics category; Originally Posted by 45guy . Great gun shop. They were willing to give me a new revolver instead, however, they didn't have one in stock. ...

Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

Thread: Smith 642 Problems

  1. #16
    Member Array Rmart30's Avatar
    Join Date
    Jun 2008
    Location
    Birmingham Alabama
    Posts
    83
    Quote Originally Posted by 45guy View Post
    . Great gun shop. They were willing to give me a new revolver instead, however, they didn't have one in stock.
    Id stick with them fellas..... hard to find someone like that


  2. #17
    VIP Member Array Eagleks's Avatar
    Join Date
    May 2008
    Location
    Kansas
    Posts
    7,883
    Check that the 'arm' or crane, that the wheel rotates out on... is all the way back as it should be. If it was not locked in correctly and in the right place, you will have all of the problems you are describing.

    Just had it happen in a new gun..... it's a Taurus 617, and the screw on the right side on it, has a spring and plunger on the end of the screw that hold the crane (left side) in place.... only no spring and no plunger. Once a new one was in, and all in place.... all worked fine.

  3. #18
    Administrator
    Array QKShooter's Avatar
    Join Date
    Dec 2004
    Location
    Off Of The X
    Posts
    35,919

    Thumbs up

    +1 Great Gun Shop. I'd be a customer there for life.

    Quote Originally Posted by Rmart30 View Post
    Id stick with them fellas..... hard to find someone like that
    Liberty Over Tyranny Μολὼν λαβέ

  4. #19
    New Member Array 45guy's Avatar
    Join Date
    Aug 2008
    Location
    Florida
    Posts
    2

    It's back

    Just received my 642 back from smith. Looks like they replaced the cylinder. The paper work from Smith says "repaired per customer complaint". The dealer suggested that I call Smith on Monday and ask them what was repaired.

  5. #20
    Member Array USMCXD's Avatar
    Join Date
    Sep 2008
    Location
    florida
    Posts
    84
    Quote Originally Posted by 45guy View Post
    Took it back to the dealer today. Everyone was puzzled. Looked at all of the options mentioned here. They called Smith and will send it back to the factory. Great gun shop. They were willing to give me a new revolver instead, however, they didn't have one in stock. Estimate I'll have it back in less than a week.
    that is really weird. i have the 638 and have had no problems. so, the lock was not stuck? i am glad to hear that they took care of ya though - that is hard to find sometimes.

    if you don't mind, please give us an update on what Smith says was the problem, when you call them.

  6. #21
    Member Array frank's Avatar
    Join Date
    Apr 2006
    Location
    Georgia
    Posts
    310
    It is a fairly common problem on all S&W revolvers. It doesn't happen often but it will make you scratch your head.
    The usual culprits were outlined above.
    Ejector rod backs out or front frame screw backs out, Both will lock the gun up.

Page 2 of 2 FirstFirst 12

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Kel Tec P-11 Problems
    By chains1240 in forum Defensive Carry Guns
    Replies: 19
    Last Post: April 16th, 2009, 04:32 PM
  2. Smith &Wesson 629 problems
    By 357sig in forum Firearm Cleaning & Maintenance
    Replies: 4
    Last Post: January 12th, 2009, 11:36 PM
  3. 59 series smith mags in a 6906 smith
    By coronel in forum General Firearm Discussion
    Replies: 4
    Last Post: July 25th, 2008, 07:35 PM
  4. H.R. 218 problems?
    By tuttleje in forum Concealed Carry Issues & Discussions
    Replies: 6
    Last Post: September 19th, 2007, 11:30 PM
  5. PPK/S problems
    By luteai in forum Defensive Carry Guns
    Replies: 23
    Last Post: April 8th, 2007, 11:48 AM

Search tags for this page

642 ejector rod plunger

,

642 problems

,
s&w 642 issues
,
smith & wesson 642 problems
,
smith 642 forum
,
smith 642 gen 2
,
smith 642 issues
,

smith 642 problems

,

smith and wesson 642 problems

,

smith wesson 642 problems

,

sw 642 problems

,
sw642 problems
Click on a term to search for related topics.