Defensive Carry banner

1 - 20 of 26 Posts

·
Registered
Joined
·
3,425 Posts
Discussion Starter #1
Lately this forum seems to be running very slowly. I click to change the page and it takes quite awhile for a response. Haven't noticed the delay on other forums.
 

·
Administrator
Joined
·
1,583 Posts
@Texas Red

I am accessing the full site from my desktop, using Chrome (operating system Windows 10) and the site is loading almost instantly for me. I also checked in Firefox and Edge.

Can you tell me what device and browser you are using to access the site?
 

·
Banned
Joined
·
374 Posts
Lately this forum seems to be running very slowly. I click to change the page and it takes quite awhile for a response. Haven't noticed the delay on other forums.
This is by far the slowest site I visit on the Net. The page load time and keyboard lag almost makes it unusable. If you aren't running a modern anti-virus, it will perform faster but you are also at risk to the mountain of attacks VerticalScope is bombarding you with each time you click or hit enter (or even move the cursor while their site is active.) What browser and OS you are running is mostly irrelevant.

These under-the-cover attacks are why VS bought this and many other sites. It's how they make their money, so they aren't likely going away.
 

·
Administrator
Joined
·
1,583 Posts
This is by far the slowest site I visit on the Net. The page load time and keyboard lag almost makes it unusable. If you aren't running a modern anti-virus, it will perform faster but you are also at risk to the mountain of attacks VerticalScope is bombarding you with each time you click or hit enter (or even move the cursor while their site is active.) What browser and OS you are running is mostly irrelevant.

These under-the-cover attacks are why VS bought this and many other sites. It's how they make their money, so they aren't likely going away.
Respectfully, we have changed very little on this site in terms of ads. Additionally, VerticalScope had already acquired this site when you joined.

I am not here to fuss and feud. I am here to help find solutions, but that means I need more information regarding how you access the site so that I can troubleshoot what is going on. Clearly this DOES make a difference since I am NOT experiencing the issues, even though I block absolutely nothing and tested from 3 different browsers.
 

·
Registered
Joined
·
1,270 Posts
Think it might be u or the Internet you use. I don't have a problem. I click and it goes as fast as my connection will let it. Try deleting your cookies and cache file to see if it speeds up
 

·
Premium Member
Joined
·
7,485 Posts
I use Opera which is "like Chrome" sort of, a little bit. But not Chrome at all. The one page that is always noticeably slow loading is my account "likes" page. The others seem to be OK. But when I click on the drop down notification to transfer to the likes page it takes about 3 to 4 times as long to load that page. This is a fairly recent occurrence. Don't know if that bit of information will help or not.
 

·
Premium Member
Joined
·
5,957 Posts
Average page load time for me is 5-8 seconds. That's on any of my devices from a 2012 iMac w/16gb ram, to my Intel i5 powered Lenovo w/16gb ram, to my iPhone 6 Plus. All units running Chrome. FB, major news sites, and other forums load faster. Also, this is with more than 20MBPS bandwidth.
 
  • Like
Reactions: Cricket

·
Registered
Joined
·
1,659 Posts
The one page that is always noticeably slow loading is my account "likes" page. The others seem to be OK. But when I click on the drop down notification to transfer to the likes page it takes about 3 to 4 times as long to load that page.
X 2...for me...all else, seems normal.
 
  • Like
Reactions: Cricket

·
Premium Member
Joined
·
7,703 Posts
Haven't had any issues here... you might try cleaning out your cache.
 
  • Like
Reactions: ghost tracker

·
Registered
Joined
·
887 Posts
No issues so far here. Running an ancient computer using Windows XP Pro and a DSL line with 6mbps download speed.
 
  • Like
Reactions: Cricket

·
Super Moderator
Joined
·
19,389 Posts
I've been here years before VS took over, and I've noticed no change in time to load any DC pages in a long time. It's also no slower than any of the other half-dozen forums I frequent, at least one other of which has the same owner.

Running Firefox 47.0 on a PC with 64-bit Win 7, and Malwarebytes. I also regularly clear out my cache and delete boatloads of .tmp files.
 

·
Registered
Joined
·
1,270 Posts
Try using a tablet instead of computer. They run faster but a little harder to wright long messages with. Unless u are already then try the cookies thing, or it could just be your connection is having a brain fart.
 

·
Registered
Joined
·
3,425 Posts
Discussion Starter #15
@Texas Red

I am accessing the full site from my desktop, using Chrome (operating system Windows 10) and the site is loading almost instantly for me. I also checked in Firefox and Edge.

Can you tell me what device and browser you are using to access the site?
I'm on a desktop running Windows 10 on Waterfox browser. I access other sites and don't experience the lag times I get here.
 

·
Super Moderator
Joined
·
23,590 Posts
I am having connectivity issues here, so I am not a reliable test dummy, but it seems about the same as always since my last network and hardware upgrade in December 2015. I can't talk the provider into a fiber bundle into my house. :rofl:

OSX 10.11.5 with Safari 9.1.1
 

·
Banned
Joined
·
2,094 Posts
Mine is running slow but its NOT the forum. Its the cheap jerks dictating how much bandwidth I get. It runs out two weeks into each month and getting worse. I purposely don't watch You tube anymore cuz it used all my bandwidth after only a few short clips...They want more $$$ to upgrade. Its extortion...
 

·
Registered
Joined
·
12,686 Posts
Mac user here, have seen no load-speed issues for almost a decade.
 
1 - 20 of 26 Posts
Top