Defensive Carry banner

1 - 11 of 11 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
My best friend sold me his Para after moving on to an EMP and regularly had issues with failure to load issues. Seeing this myself I sent it to Para with a detailed explanation of the issue long with pictures of the the problem I took in the range at the time. The two magazines could be the issue and I included that note on the sheet I included in the box.

Received it yesterday after two weeks at Para with a work order explaning that there is nothing wrong and everything tested/inspected is within specs. Lovley. So to prove their claim I cleaned,lubed it, took it to the range today and was only able to buy one box of ammo due to a nationwide ammo shortage. great. So I put up with it and take it to the back, shoot half the box with no issues at all with both magazines, outstanding. Come toward 3/4 of the box I got 2-3 failure to EJECT issues. Unacceptable. Called Para Immediately and explained my problem as calm as one can be in this angering situation. Turns out that the techs didn't inspect nor test fire the magazines included with my gun. Ended up sending it back today though the dealer at the range.

I burned a lot of money sending the gun back to Para twice, Not sure if I can get a refund for the shipping because it was privately sold to me by a friend, whom has the original proof of purchase but not sure if it will help since it is my name that sent it through.

Sorry for the long winded post. Just venting some frustration. Feel free to shine in on what to expect. If I get another problem after sending this gun back, I might just sell it and get an EMP.

My head hurts, do the happy dance :danceban:
 

·
Registered
Joined
·
454 Posts
People have accused me of just Para bashing..when I tell them of my problems with Para...they don't care about your problems with their products. I lost so much money dealing with Para that it isn't even funny. I would dump that lemon and get me an emp or a SA Micro. Sorry that this has happened to you..Robbie
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
To Para's defense I haven't heard many reliability issues on their products. By chance the one I have is one of the bad apples I suppose. I still have faith that Para will fix this problem. Hopefully they will dig deeper and find the culprit this time. I'm still surprised how a FTF issue turns into a FTE issue if they did no adjustments to my weapon.... I'm confident I'm doing everything on my end to maintain and properly handle the gun (cleaned, CLP'd, Lubed mating surfaces and barrel properly as well as forward position when shooting).
 

·
Registered
Joined
·
454 Posts
Go to m1911.org and look under the para section and you will see plenty of Para reliablility issues. Alot of guys are having trouble with their Paras... Robbie
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Read the whole " No More Para Ord for me!!!! " thread. Not helping my confidence in this weapon let alone trusting my life and loved ones on it.
 

·
Registered
Joined
·
454 Posts
Yep..I went thru a lot trying to make those 2 pistols work... I am a manufacturers rep by trade and definitely know how to talk to companies..I was dumbfounded dealing with them... I wouldn't trust my life to one... every colt I have bought worked out of the box with no problems...never had to shoot 200 rds... Hope this works out for you..Robbie
 

·
Moderator
Joined
·
8,501 Posts
I know this sounds silly but if it shot well with the mags for the first 30 to 40rounds and then tanked it could be you're over lubing. Too much oil can trap dirt and gum up a gun fast. Try shooting it dry for a change and see what happens.
 

·
Registered
Joined
·
2,198 Posts
What kind of ammo are you using? I have a Kimber HD-II .38 Super that had the same problems, FTF, FTE, when I used wimpy PMC ammo. Anything else it ran fine. Consider that if the slide does not recoil far enough back, it won't be able to pick up a new round nor eject the old casing. If you think it's a magazine issue, why not try firing it with different mags?
When I was an LEO I carried a Para P-14 and it ran fine all the time straight out of the box. I currently own a Para C-6 and C-7 and have never had a problem with either. Both are factory with no modifications except different grips.
 

·
Banned
Joined
·
56 Posts
I recently traded my Warthog for a S'field xd45c after having NUMEROUS feed/ejects with it. Different mags, different ammo, same problem. I've had zero issues with the S'field .45 (also have an xd9sc). Both run like a scalded dog.
 
1 - 11 of 11 Posts
Top