Defensive Carry banner

1 - 6 of 6 Posts

·
Registered
Joined
·
251 Posts
Discussion Starter #1
This is my first 1911. Have 100 rounds thru it so far. Love the gun but when I use the 8 round factory supplied magazine I have to really whack it for it to latch and then the first round doesn't want to feed the first round when I slingshot the slide. And the 8th round goes into the mag hard. Problem goes away when I only put 7 rounds in the mag. Magazine bodies appear to be the same length. Problem does does not exist with the factory supplied 7 round mag.

In the picture the mag on the left is supposed to be the 8 rounder and rt side is 7 round. I disassembled both mags, lightly oiled and reassembled. Same problem. When I look at the parts the major difference seems to be the length and diameter (shorter and lighter) of the wire used in the spring on the 8 round mag.

Thought I'd ask here in case I'm missing the obvious before calling S&W. Any thoughts would be greatly appreciated.

image.jpg image.jpg
 

·
Registered
Joined
·
37,165 Posts
The 8-rounder a new mag? I'd stuff it full and let it sit a couple of days before I got too concerned about it. New mags can be overly stiff until the spring eases up a bit. Also oiling mags only lets the gunk build up faster. Use a dry lube or graphite powder instead. Atracks less garbage.
 

·
Administrator
Joined
·
143,727 Posts
Ditto what OldVet said. That is a fairly common problem with some spanky new 8 round magazines.
 

·
Premium Member
Joined
·
7,465 Posts
Yup. My G30 mags had the same problem when I first got it.

... and I'm still jealous over your new E-series. Whec wants one bad.
 

·
Registered
Joined
·
4,469 Posts
Also try loading the gun with the slide open.
 
1 - 6 of 6 Posts
Top